Workbench is unavailable
Incident Report for Expel, Inc.
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 19:21 EDT
Monitoring
We have implemented a fix. We will continue to monitor Workbench functionality
Posted Mar 28, 2024 - 18:48 EDT
Update
We are continuing to investigate this issue.
Posted Mar 28, 2024 - 18:38 EDT
Investigating
Workbench is currently unavailable. We are currently investigating. Please expect another update @ 7pm ET
Posted Mar 28, 2024 - 18:33 EDT
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login) and Workbench features (Investigative actions, File uploads).