The Alert Analysis Dashboard is not displaying data

Incident Report for Expel, Inc.

Resolved

The incident has been resolved and the Alert Analysis Dashboard is once again fully available. No customer data was lost, and SOC operations were not impacted.
Posted Oct 09, 2025 - 10:25 EDT

Monitoring

We have implemented a fix and believe the incident to be resolved. We are monitoring the health of the infrastructure and will resolve this if there are no outstanding issues. Please let us know if you are experiencing any problems.
Posted Oct 09, 2025 - 10:23 EDT

Investigating

At 13:30UTC, we began experiencing a problem with the Alert Analysis Dashboard that is preventing users from seeing metrics on that page only. Alert ingestion & SOC operations are not affected. We will provide an update by 14:30UTC.
Posted Oct 09, 2025 - 09:56 EDT