Workbench Unavailable
Incident Report for Expel, Inc.
Resolved
Workbench and alert ingestion are now both operational. All delayed alerts have been ingested and no alerts were lost during the process.
Posted May 20, 2020 - 13:38 EDT
Update
Expel Workbench is now operational. We are still experiencing issues with alert ingestion and continuing to investigate the issue.
Posted May 20, 2020 - 13:23 EDT
Investigating
We are currently investigating this issue.
Posted May 20, 2020 - 13:01 EDT
This incident affected: Notifications (Email), Workbench availability (Workbench global network connectivity, Workbench login), Workbench features (Investigative actions, File uploads), and Alert ingestion.