Delay in phishing submissions
Incident Report for Expel, Inc.
Resolved
Phishing is fully operational. No submissions were lost.
Posted Nov 02, 2023 - 14:07 EDT
Identified
We have identified the issue and are starting to mitigate it. We are currently ingesting the backlog of phishing submissions.
Posted Nov 02, 2023 - 13:59 EDT
Update
We are investigating the cause and will provide an update by 2:15 PM EDT.
Posted Nov 02, 2023 - 13:42 EDT
Investigating
We have detected a degradation in our phishing service that is causing submission ingestion delays.
Posted Nov 02, 2023 - 13:42 EDT
This incident affected: Phishing submissions.