The incident has been resolved, and all systems are once again fully available. No customer data was lost.
Posted Oct 20, 2025 - 08:35 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:24 EDT
Update
Expel Workbench is fully operational, has processed the full backlog of alerts, and is ingesting and processing current alerts normally. We will continue to monitor and provide additional updates as necessary.
Posted Oct 20, 2025 - 07:59 EDT
Update
We are continuing to monitor. Workbench continues to process the backlog of alerts. Please note that no customer data was lost as a result of the AWS outage. We will post the next update at 12:00pm UTC.
Posted Oct 20, 2025 - 07:31 EDT
Update
We are continuing to monitor. Workbench continues to process the backlog of alerts. Amazon reports that it has mitigated the underlying the DNS issue, and most AWS Service operations are succeeding normally now. Please note that no customer data was lost as a result of the AWS outage. We will post the next update at 11:30am UTC.
Posted Oct 20, 2025 - 07:04 EDT
Update
We are continuing to monitor. Workbench is working the backlog of alerts. Please note that no customer data was lost as a result of the AWS outage. We will post the next update at 11:00am UTC.
Posted Oct 20, 2025 - 06:33 EDT
Monitoring
Amazon Web Services reported an outage affecting AWS services in the US-EAST-1 region starting at approximately 06:50am UTC. AWS communicated that it identified the root cause and took mitigation actions, and that it’s seeing significant signs of recovery.
This outage is affecting how Expel Workbench ingests and processes alerts, as well as how we communicate with customers. At this time, Expel Workbench is operating normally. Our systems are working through a backlog of security device data.
Posted Oct 20, 2025 - 06:06 EDT
This incident affected: Notifications (Email, Slack, Teams, Ticketing systems (via email, such as Jira), PagerDuty, Opsgenie) and Alert ingestion.