Security Device Credentials Availability

Incident Report for Expel, Inc.

Resolved

The incident has been resolved, and all systems are once again fully available. No customer data was lost, and all previously-accessible security devices are once again accessible and ingesting alerts.
Posted May 01, 2026 - 16:01 EDT

Monitoring

We have implemented a fix and believe the incident to be resolved. We are seeing customer security devices returning to healthy status. We are monitoring the health of the infrastructure and will post another update by 4pm EDT.
Posted May 01, 2026 - 15:09 EDT

Investigating

At 2pm EDT, we began experiencing a problem with the customer device secrets service that is preventing our infrastructure from accessing customer security devices. We will provide an update by 3:30pm EDT.
Posted May 01, 2026 - 14:50 EDT
This incident affected: Alert ingestion.