Some Notifications are delayed
Incident Report for Expel, Inc.
Resolved
All notifications are being delivered as expected and we're taking steps to ensure this does not happen again in the future.
Posted Oct 01, 2024 - 15:19 EDT
Investigating
We're experiencing a delay in delivering some notifications. We are actively investigating the issue and will provide another update by 3:30 pm EST.
Posted Oct 01, 2024 - 14:58 EDT
This incident affected: Notifications (Email, Slack, Teams, Ticketing systems (via email, such as Jira), PagerDuty, Opsgenie, ServiceNow).