Intermittent Issues with Phishing Submissions

Incident Report for Expel, Inc.

Resolved

This issue has been resolved. We're no longer receiving reports of failed phishing submissions.
Posted Oct 28, 2024 - 09:57 EDT

Update

We believe we have identified the issue and are working with our customers to verify. We will have another update at Monday 10/28/2024 10am ET.
Posted Oct 25, 2024 - 15:40 EDT

Update

We believe we have identified the issue and are working with our customers to verify. We will have another update at 4pm ET.
Posted Oct 25, 2024 - 12:49 EDT

Update

We believe we have identified the issue and are working with our customers to verify. We will have another update at 1pm ET.
Posted Oct 25, 2024 - 09:54 EDT

Update

We believe we have identified the issue and are working with our customers to verify. We will have another update at tomorrow 10am ET.
Posted Oct 24, 2024 - 15:49 EDT

Update

We believe we have identified the issue and are working with our customers to verify. We will have another update at 4pm ET.
Posted Oct 24, 2024 - 12:41 EDT

Identified

We believe we have identified the issue and are working with our customers to verify. We will have another update at 1pm ET.
Posted Oct 24, 2024 - 09:58 EDT

Update

We are still working with our service provider to identify the issue. We will have another update at 10/24/24 10am ET.
Posted Oct 23, 2024 - 15:58 EDT

Update

We are still working with our service provider to identify the issue. We will have another update at 4pm ET.
Posted Oct 23, 2024 - 12:52 EDT

Update

We are still working with our service provider to identify the issue. We will have another update at 1pm ET.
Posted Oct 23, 2024 - 09:16 EDT

Investigating

Some of our Exchange customers have reported intermittent failures with phishing submissions. We're working with our service provider on identifying the root cause. We'll provide an update at 10am ET.
Posted Oct 22, 2024 - 18:04 EDT
This incident affected: Phishing submissions.