Workbench Expel Alert Count Discrepancy

Incident Report for Expel, Inc.

Resolved

The incident has been resolved, and all alerts counts are once again accurate. No customer data was lost, and SOC operations were not impacted.
Posted May 13, 2026 - 12:46 EDT

Update

We have remediated the issue with Expel Alerts count being inflated for customers by shifting to a different source of statistics. We are working on fixing the underlying issue with our main source of count data. We will provide another update by 1pm EDT.
Posted May 13, 2026 - 12:38 EDT

Identified

We are aware of an issue with the Expel Alerts count being inflated for customers. We have identified the root cause and are working on a remediation. SOC operations and alert ingestion are not affected. We will provide another update by 1pm EDT.
Posted May 13, 2026 - 12:23 EDT