Delayed notifications
Incident Report for Expel, Inc.
Resolved
Our notification system is now processing new notifications without delay. There is a historical window of notifications from 12:00pm to 3:00pm Eastern that have not been sent. We're currently working towards reprocessing those notifications.
Posted Sep 13, 2021 - 15:57 EDT
Identified
We are currently experiencing a delay in processing notifications due to degraded performance with our delivery provider. This affects all notification channels including email, Slack, Teams, PagerDuty, ServiceNow, OpsGenie and ticketing systems. We expect to be caught up by 4pm Eastern.
Posted Sep 13, 2021 - 14:11 EDT
This incident affected: Workbench features (Email notifications) and Slack channels for customers.