Workbench performance degraded
Incident Report for Expel, Inc.
Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 12:37 EST
Monitoring
The incident has been resolved, and Workbench performance is back to normal levels. No customer data was lost, and SOC operations were minimally impacted. We are continuing to monitor.
Posted Dec 13, 2023 - 12:16 EST
Investigating
We are experiencing a problem with Workbench performance and API calls. SOC operations are currently minimally impacted and alert ingestion is not affected. We will provide an update at 1pm ET.
Posted Dec 13, 2023 - 11:47 EST
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login).