MS Teams notifications unavailable

Incident Report for Expel, Inc.

Resolved

MS Teams notifications are now available. All previously failed MS Teams notifications have been sent.
Posted Jun 21, 2022 - 13:28 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 21, 2022 - 11:51 EDT

Investigating

We are investigating an issue that is causing MS Teams notifications not to be delivered. We will provide an update by 12:00 EDT.
Posted Jun 21, 2022 - 11:25 EDT
This incident affected: Notifications (Teams).