Delayed Notifications

Incident Report for Expel, Inc.

Resolved

This issue has been resolved. All notifications in the backlog have been delivered and new notifications are being delivered as normal.
Posted Apr 25, 2026 - 14:09 EDT

Investigating

At 1pm ET, we began experiencing a problem with our notification system that is causing notification delays to our customers.  We will provide an update by 2:30pm ET.
Posted Apr 25, 2026 - 13:42 EDT
This incident affected: Notifications (Email, Slack).