Workbench unavailable
Incident Report for Expel, Inc.
Resolved
Workbench is now available, alert ingestion has resumed, and all systems are operational. Thank you for your patience.
Posted Jul 17, 2020 - 14:47 EDT
Investigating
We are currently experiencing degraded service with Workbench. We will be initiating immediate maintenance which will result in Workbench becoming unavailable and alert ingestion becoming delayed. We expect the maintenance to be completed within twenty minutes. No alerts will be lost.
Posted Jul 17, 2020 - 14:35 EDT
This incident affected: Notifications (Email), Workbench availability (Workbench global network connectivity, Workbench login), Workbench features (Investigative actions, File uploads), and Alert ingestion.