Investigative Actions are delayed
Incident Report for Expel, Inc.
Resolved
The incident has been resolved, Investigative Actions are now processing at their normal rate.
Posted Jun 16, 2023 - 13:05 EDT
Update
We are continuing to see delays of 15 minutes in the processing of Investigative Actions. We have increased the number of worker processes. The delay is improving, but we are continuing to monitor. We will provide an update by 1:30 et.
Posted Jun 16, 2023 - 12:48 EDT
Identified
We are seeing delays of 20-25 minutes in the processing of Investigative Actions. We have identified the root cause. The delay is improving, but we are continuing to monitor. We will provide an update by 12:45et.
Posted Jun 16, 2023 - 12:31 EDT
This incident affected: Workbench features (Investigative actions).