Investigations inadvertent metadata update

Incident Report for Expel, Inc.

Resolved

We have restored the correct "updated at" metadata for these records. No further unintentional notifications should be triggered.
Posted Jun 05, 2025 - 22:39 EDT

Monitoring

We have corrected the incorrect "updated at" metadata for investigation records and we are currently monitoring system activity.
Posted Jun 05, 2025 - 22:12 EDT

Identified

At approximately 11:20 am Eastern Time "updated at" metadata for Investigation records were incorrectly altered to a more recent time. This has triggered unintentional notifications to organizations.

We are currently working to restore the correct "updated at" metadata for these records
Posted Jun 05, 2025 - 21:22 EDT