Workbench Availability

Incident Report for Expel, Inc.

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 13:33 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 09, 2026 - 13:24 EDT

Monitoring

We have identified the issue, have rolled out a fix and are monitoring the situation.
Posted Jun 09, 2026 - 13:22 EDT

Update

Workbench is still experiencing connectivity issues. We are still investigating the issue and will provide an update in 1 hour.
Posted Jun 09, 2026 - 12:42 EDT

Investigating

Workbench is currently experiencing connectivity issues and may be inaccessible for some users. We are investigating the issue and will provide an update within an hour.
Posted Jun 09, 2026 - 11:40 EDT
This incident affected: Workbench availability (Workbench global network connectivity).