Workbench Availability

Incident Report for Expel, Inc.

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 13:34 EDT

Monitoring

We have rolled back the code change the caused the issue, and we believe we have resolved the login outage. We will continue monitoring login availability, and will update again or resolve the incident by 2:00pm EDT.
Posted Mar 11, 2025 - 13:14 EDT

Identified

We have identified an issue with a recent rollout of code that we believe to be the cause of the outage, and are currently rolling back to the previous known-good version. Please expect another update by 1:30pm EDT.
Posted Mar 11, 2025 - 13:10 EDT

Investigating

At 12:40pm EDT, we began experiencing a problem with workbench that is preventing users from logging in. We will provide an update by 1:30pm EDT.
Posted Mar 11, 2025 - 12:53 EDT
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login).