Workbench Availability

Incident Report for Expel, Inc.

Resolved

The incident has been resolved, and all systems are once again fully available. No customer data was lost, and SOC operations were not impacted.
Posted Mar 12, 2025 - 14:01 EDT

Monitoring

The upstream service provider has resumed healthy service, and we have resumed ingesting alerts. No events were lost during this incident. We will continue monitoring the issue and provide another update by 2:00pm EDT or resolve the incident if we see no further recurrence of the problem.
Posted Mar 12, 2025 - 13:46 EDT

Update

We have tentatively identified the root cause as an issue with our upstream service provider. We are continuing to investigate the source of the issue. Alert ingestion from Azure continues to be degraded. SOC operations are not otherwise affected. We will provide another update by 2:00pm EDT.
Posted Mar 12, 2025 - 13:32 EDT

Update

We are continuing to investigate the issue. Please expect another update by 1:30pm EDT.
Posted Mar 12, 2025 - 13:09 EDT

Investigating

At 12:12pm EDT, we began experiencing a problem with Microsoft Azure security devices that is preventing us from ingesting alerts. We will provide an update by 1:00pm EDT.
Posted Mar 12, 2025 - 12:41 EDT
This incident affected: Alert ingestion.