Investigative actions delayed
Incident Report for Expel, Inc.
Resolved
The incident with investigative actions has been resolved.
Posted Oct 21, 2023 - 10:26 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 21, 2023 - 10:03 EDT
Monitoring
We noticed a delay in processing of investigative actions, have identified the source of the problem, implemented a fix, and are monitoring the recovery.
Posted Oct 21, 2023 - 10:03 EDT
This incident affected: Workbench features (Investigative actions).