Delay in sending email, slack and MS Teams notifications from Workbench

Incident Report for Expel, Inc.

Resolved

We have confirmed that the incident has been resolved. Email, slack and MS Teams notifications from Workbench are being delivered within normal timeframes.
Posted Oct 08, 2025 - 06:50 EDT

Update

We are no longer observing delays in delivering email, slack and MS Teams notifications from Workbench. We will continue to monitor for the next hour as we work with our vendor to confirm that the issue is resolved.
Posted Oct 08, 2025 - 06:04 EDT

Monitoring

We continue to experience a delay of approximately 10–15 minutes in delivering email, Slack, and Microsoft Teams notifications from Workbench.

Our team has escalated the issue with our vendor and is actively monitoring the situation. We’ll provide an update here as soon as we have more information or when service performance returns to normal.
Posted Oct 08, 2025 - 05:42 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 08, 2025 - 05:34 EDT

Identified

We have identified an issue with a 3rd party vendor that is causing a 10-15 minute delay in sending email, slack and MS Teams notifications from Workbench. Alert ingestion is not affected. Please be aware that this delay applies to all client notifications, such as Verify Actions and New Incident Notifications. There is no other impact to SOC operations. Customers can continue to request support as usual (ticket creation is not affected by this delay).
Posted Oct 08, 2025 - 04:59 EDT
This incident affected: Notifications (Email, Slack, Teams) and Slack channels for customers.