Microsoft has confirmed that the O365 outage has been completely resolved. Our integration with O365 remains healthy and no customer data was lost.
Posted Oct 29, 2025 - 22:22 EDT
Update
Our integration with O365 has become healthy and the backlog of events have been processed. We will continue to monitor the O365 service outage and will provide updates as they come.
Posted Oct 29, 2025 - 17:57 EDT
Monitoring
Our integration with O365 has become healthy. We are currently ingesting and processing a backlog of events and will provide another update in 60 minutes.
Posted Oct 29, 2025 - 16:59 EDT
Update
Microsoft has reported an outage affecting O365 services. As a result of this outage, our integration with O365 is currently reporting as unhealthy.
We are actively monitoring this issue and will provide an update within 60 minutes, or as soon as more information is available.
Posted Oct 29, 2025 - 16:09 EDT
Update
Microsoft has reported an outage affecting O365 services. As a result of this outage, our integration with O365 is currently reporting as unhealthy.
We are actively monitoring this issue and will provide an update within 60 minutes, or as soon as more information is available.
Posted Oct 29, 2025 - 15:09 EDT
Update
Microsoft has reported an outage affecting O365 services. As a result of this outage, our integration with O365 is currently reporting as unhealthy.
We are actively monitoring this issue and will provide an update within 60 minutes, or as soon as more information is available.
Posted Oct 29, 2025 - 14:13 EDT
Identified
Microsoft has reported an outage affecting O365 services. As a result of this outage, our integration with O365 is currently reporting as unhealthy.
We are actively monitoring this issue and will provide an update within 60 minutes, or as soon as more information is available.
Posted Oct 29, 2025 - 13:17 EDT
This incident affected: Workbench features (Investigative actions) and Alert ingestion.