Email Notifications Delayed
Incident Report for Expel, Inc.
Resolved
Email notifications are being sent again. All notifications queued during this incident have been sent.
Posted 10 months ago. Nov 01, 2018 - 07:21 EDT
Identified
Email notifications are not being sent. We have identified the issue and are working on a fix. We will contact customers about any security incidents found via other mechanisms until this is resolved. Once it is resolved, all pending email notifications will be sent.
Posted 10 months ago. Nov 01, 2018 - 05:53 EDT
This incident affected: Workbench features (Email notifications).