Workbench alert triage capability degraded
Incident Report for Expel, Inc.
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 14:54 EST
Monitoring
We've identified the cause and implemented a fix for the Workbench triage capability issue. We're continuing to monitor the situation.
Posted Nov 05, 2019 - 13:08 EST
Investigating
We've identified an issue causing Workbench to fail to present evidence for certain alerts. We're actively investigating the issue.
Posted Nov 05, 2019 - 12:50 EST