Workbench error rate increase
Incident Report for Expel, Inc.
Resolved
This incident has been resolved.
Posted Feb 09, 2023 - 13:14 EST
Update
The elevated error rate has subsided. We are still investigating reports of slowness and Ruxie actions not populating. We'll update by 2pm ET
Posted Feb 09, 2023 - 13:02 EST
Investigating
Our Workbench is experiencing elevated error rates. We will provide an update by 1:30 pm ET.
Posted Feb 09, 2023 - 12:41 EST
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login) and Workbench features (Investigative actions, File uploads).