The incident has been resolved, and Workbench investigative and remediation actions are fully available.
Posted May 13, 2025 - 18:07 EDT
Monitoring
We have resolved the root issue and our workbench actions capabilities have fully resumed normal operations as of 3:15 pm ET
Posted May 13, 2025 - 15:32 EDT
Update
While we have isolated the system with degraded performance, we continue the technical triage of the issue to determine the root case and restore full service as quickly as possible.
We will provide an update at 4 PM ET
Posted May 13, 2025 - 15:08 EDT
Investigating
We are actively investigating intermittent service degradation to Workbench investigative and remediation actions. Customers may not be able to access some sections of the portal as a side effect. We will provide an update at 3 PM ET
Posted May 13, 2025 - 14:37 EDT
This incident affected: Workbench features (Investigative actions).