Alert Ingestion Delay for AWS Cloudtrail Events

Incident Report for Expel, Inc.

Resolved

The backlog has been processed. The incident has been resolved. No customer data was lost, and SOC operations were not impacted.
Posted Jul 09, 2025 - 19:37 EDT

Update

The backlog is still being processed. We will provide another update by 7:30pm ET.
Posted Jul 09, 2025 - 19:00 EDT

Monitoring

We have implemented a fix and believe the incident to be resolved. We are currently processing the backlog. We will provide another update by 7pm ET.
Posted Jul 09, 2025 - 18:32 EDT
This incident affected: Alert ingestion.