Slack Migration Delay
Incident Report for Expel, Inc.
Resolved
Our Slack migration has completed and Slack is back online, any backlog of automated notifications will be delivered. You may see some activity out of order. Workbench will have the current status of all alerts and investigations.
Posted Dec 17, 2022 - 22:44 EST
Monitoring
The Slack migration scheduled for this evening is taking longer than anticipated. We are working with Slack to determine the delay and will post an update by 10:45pm EST. While Slack is down our team continues to monitor your alerts and will investigate and respond immediately to threats as we always do and Workbench is still fully functional. For reaching us or escalating any security incidents please use other configured escalation methods.

Workbench remains fully functional during this time. You are able to login and see your alerts and our SOC analysts working in real-time as usual.

In the event of a security incident for your organization during the Slack down time, our SOC will notify you via your configured escalation method (email, PagerDuty, etc). If you have an urgent security concern during this time, you can reach our Security Operation Center by emailing soc@expel.io or leaving a message on our SOC hotline (+1-844-397-5762) and the SOC will be immediately notified.
Posted Dec 17, 2022 - 22:11 EST
This incident affected: Notifications (Slack) and Slack channels for customers.