Phishing Alert ingestion degraded
Incident Report for Expel, Inc.
Resolved
This incident has been resolved. Phishing submission alerts are flowing as expected.
Posted Aug 24, 2023 - 16:14 EDT
Monitoring
Expel has applied a fix that mitigates the phishing submission ingestion delays. We are currently monitoring the service to ensure continued normal operation.
Posted Aug 24, 2023 - 15:15 EDT
Identified
Expel has identified the issue. Efforts to mitigate the issue and restore full phishing service are ongoing.
Posted Aug 24, 2023 - 15:09 EDT
Investigating
Our phishing submission pipeline is experiencing periodic delays in Workbench. All alerts are still being processed, but the delays are impacting analysis and triage of phishing submissions.

This degradation is only affecting phishing submission alerts. All other alerts in workbench are unaffected.
Posted Aug 24, 2023 - 14:46 EDT
This incident affected: Phishing submissions.