Workbench Degraded

Incident Report for Expel, Inc.

Resolved

This incident has been resolved.
Posted Mar 16, 2024 - 09:10 EDT

Monitoring

We have implemented a fix and believe the incident to be resolved. We are monitoring the health of the infrastructure and will resolve this if there are no outstanding issues. Please let us know if you are experiencing any problems.
Posted Mar 16, 2024 - 08:57 EDT

Investigating

At 8:03AM ET, we began experiencing a problem with workbench that is preventing users from accessing workbench. SOC operations and alert ingestion are affected. We will provide an update at 9:00AM ET.
Posted Mar 16, 2024 - 08:48 EDT
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login), Workbench features (Investigative actions, File uploads), and Assembler connectivity, Alert ingestion.