Workbench Access Degraded

Incident Report for Expel, Inc.

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 12:21 EDT

Monitoring

At 11:16AM ET, we began experiencing a problem with Workbench that is preventing users from accessing Workbench.

We have identified the root cause and are working on a remediation. We have rolled out a previous, working version of Workbench and service has been restored. SOC operations were affected, but alert ingestion was not affected. We will continue monitoring and provide another update by 12:30pm ET.
Posted Apr 14, 2025 - 11:44 EDT
This incident affected: Workbench availability (Workbench global network connectivity).