Workbench Degraded
Incident Report for Expel, Inc.
Resolved
The incident is resolved and all systems are operational.
Posted May 04, 2022 - 12:54 EDT
Monitoring
The hotfix has been applied and Workbench has stabilized. We are continuing to monitor the fix.
Posted May 04, 2022 - 12:27 EDT
Identified
We have identified the issue and are deploying a hotfix.
Posted May 04, 2022 - 12:16 EDT
Investigating
Workbench is currently in a degraded state and may be inaccessible. We are actively troubleshooting the incident.
Posted May 04, 2022 - 11:46 EDT
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login) and Workbench features (File uploads).