Follow-on Infrastructure Maintenance
Incident Report for Expel, Inc.
Resolved
Infrastructure maintenance is complete. Workbench and investigative actions are fully operational. Thank you for your patience.
Posted Feb 12, 2020 - 21:36 EST
Identified
We've identified an issue causing a negative performance impact on investigative actions related to our previous infrastructure maintenance. We are performing follow-on maintenance to address the problem which involves taking down Workbench. We expect the maintenance to take between 10-25 minutes and will provide updates immediately upon completion.
Posted Feb 12, 2020 - 21:20 EST
This incident affected: Notifications (Email), Workbench availability (Workbench global network connectivity, Workbench login), Workbench features (Investigative actions, File uploads), and Alert ingestion.