Customer email notifications and phishing submission ingestion down
Incident Report for Expel, Inc.
Resolved
Mailgun said they've made significant progress in resolving the issue. Our systems continue to work as expected, so we are calling this incident Resolved.
Posted Jun 09, 2022 - 14:00 EDT
Monitoring
Phishing submissions and customer email notifications are now available but email notifications may still be delayed. All pending notifications have been delivered and Phishing submissions can now be resubmitted. We will leave this incident in the monitoring status until Mailgun says the issue is fully resolved.
Posted Jun 09, 2022 - 10:17 EDT
Identified
Customer email notifications and Phishing submissions are currently unavailable due to an ongoing outage with Mailgun (https://status.mailgun.com). Non-email based notifications are unaffected by the incident. Delayed email notifications will be sent and Phishing submissions can be resubmitted once Mailgun's outage has been resolved. We're monitoring the situation and will provide an update by 11:00am Eastern.
Posted Jun 09, 2022 - 09:28 EDT
This incident affected: Notifications (Email, Ticketing systems (via email, such as Jira)).