Alert Ingest Delay

Incident Report for Expel, Inc.

Resolved

The incident has been resolved, and all systems are once again fully available. No customer data was lost.
Posted Aug 08, 2025 - 01:21 EDT

Monitoring

The system is recovering. Alert ingestion is catching up.
Posted Aug 08, 2025 - 01:04 EDT

Update

Root cause still under investigation but system is recovering. We will provide an update by 1:30am.
Posted Aug 08, 2025 - 00:23 EDT

Investigating

At 7pm ET, we began experiencing a problem with alert ingestion. SOC operations are affected, but will catch up once service is restored; no data will be lost. We will provide an update by 12:30AM.
Posted Aug 07, 2025 - 23:28 EDT
This incident affected: Alert ingestion.