Phishing Email Ingestion Delays

Incident Report for Expel, Inc.

Resolved

This incident has been resolved.
Posted 1 year ago. Feb 22, 2024 - 15:34 EST

Investigating

We are currently investigating an issue resulting in delayed phishing receipt of phishing submissions.
Posted 1 year ago. Feb 22, 2024 - 13:24 EST
This incident affected: Phishing submissions.