Delivery failure for Teams messages

Incident Report for Expel, Inc.

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 13:17 EST

Monitoring

The underlying issue has been resolved

We are monitoring the health of the infrastructure and will resolve this if there are no outstanding issues. Please let us know if you are experiencing any problems.
Posted Nov 18, 2025 - 10:50 EST

Identified

Workbench cannot currently deliver notifications to Microsoft Teams. The issue began around 9:45am ET. Expel is actively investigating the issue to determine if it is related to the larger Cloudflare outage.

We recommend you utilize email notifications in the interim, and can confirm communicating with Expel personnel via Microsoft Teams still works. The issue is specific to Workbench notifications.
Posted Nov 18, 2025 - 10:34 EST
This incident affected: Notifications (Teams).