Alert Ingestion Delayed

Incident Report for Expel, Inc.

Resolved

Alert ingestion has caught up and is no longer delayed. This incident has been resolved.
Posted Aug 11, 2025 - 18:44 EDT

Monitoring

Alert ingestion is still delayed but catching up. We have taken steps to mitigate the issue and are monitoring to ensure recovery. We will provide another update by 7:00pm EDT.
Posted Aug 11, 2025 - 18:30 EDT

Update

Alert ingestion is still delayed. We have taken steps to mitigate the issue and are monitoring to ensure recovery. We will provide another update by 6:30pm EDT.
Posted Aug 11, 2025 - 17:50 EDT

Update

Alert ingestion is still delayed. We have encountered further issues and are working on identifying the root cause. We will provide another update by 5:30pm EDT.
Posted Aug 11, 2025 - 16:43 EDT

Update

Alert ingestion is still delayed. We have identified the root cause and are working on a remediation. We will provide another update by 4:30pm EDT.
Posted Aug 11, 2025 - 16:05 EDT

Update

Alert ingestion is still delayed. We have identified the root cause and are working on a remediation. We will provide another update by 4:00pm EDT.
Posted Aug 11, 2025 - 15:33 EDT

Identified

Alert ingestion is currently delayed. We have identified the root cause and are working on a remediation. We will provide another update by 3:30pm EDT.
Posted Aug 11, 2025 - 14:47 EDT
This incident affected: Workbench features (Investigative actions) and Alert ingestion.