Slack Service Disruption
Incident Report for Expel, Inc.
Resolved
Slack declared their service incident resolved at 4:51 U.S. Eastern time (08:41 UTC). Details at https://status.slack.com/2019-04-04.
Posted 5 months ago. Apr 05, 2019 - 08:56 EDT
Investigating
Slack is currently experiencing a service disruption.

As a result you may experience problems with slack messages being received. For urgent issues please reach out to soc@expel.io.

For more information on this outage please see https://status.slack.com/2019-04/cd8c3560451f0724
Posted 5 months ago. Apr 04, 2019 - 23:34 EDT
This incident affected: Slack channels for customers.