Alert Ingestion Outage
Incident Report for Expel, Inc.
Resolved
All Expel service components are now operational. The issues were related to ISP connectivity problems with one of our cloud hosted service providers.

We have confirmed that alert ingestion was delayed during this outage; however, no customer data was lost. As always, we will continue monitoring all Expel service components and keep our customers updated on any issues.
Posted Apr 21, 2020 - 16:39 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 21, 2020 - 15:31 EDT
Monitoring
Expel alert ingestion has resumed and the reported assembler connectivity issues are slowly recovering. We are still actively monitoring the situation and will provide additional updates as necessary.
Posted Apr 21, 2020 - 15:11 EDT
Identified
There are multiple internet service providers that are experiencing widespread service degradation. As a result, multiple components of the Expel service are currently unavailable, including real-time alert ingestion. We are actively investigating mitigation options and encourage customers to triage security alerts that are normally monitored by Expel. Please reach out in your Slack channel or email us at soc@expel.io for immediate assistance.
Posted Apr 21, 2020 - 14:45 EDT
This incident affected: Assembler connectivity and Alert ingestion.