Workbench Performance Degraded
Incident Report for Expel, Inc.
Resolved
Workbench performance degradation has been resolved.
Posted Mar 06, 2020 - 11:59 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2020 - 08:18 EST
Investigating
Workbench is experiencing delayed response times. We are investigating the issue.
Posted Mar 06, 2020 - 08:01 EST