Some email notifications not being delivered
Incident Report for Expel, Inc.
Resolved
This incident was resolved this morning and all email notifications are now being delivered as intended. We are continuing to analyze what emails were not delivered over what time period and will communicate those details when we have them.
Posted Mar 25, 2020 - 12:59 EDT
Update
Our testing uncovered another issue that had to be fixed to fully resolve this problem; we now expect this issue to be resolved by noon U.S. Eastern tomorrow.
Posted Mar 24, 2020 - 17:13 EDT
Update
We are testing the fix for this issue and expect it to be deployed by 5 PM U.S. Eastern today.
Posted Mar 24, 2020 - 13:40 EDT
Identified
We have identified the cause of the problem and expect a fix to be deployed by noon U.S. Eastern tomorrow. We have confirmed that Slack and PagerDuty notifications are not affected by this problem; they are all being delivered to users as expected.
Posted Mar 23, 2020 - 20:32 EDT
Investigating
Some email notifications are not being delivered. We are investigating the cause. Slack and PagerDuty notifications are being delivered to all users as expected.
Posted Mar 23, 2020 - 17:23 EDT
This incident affected: Workbench features (Email notifications).