Email Notification Sending Delayed
Incident Report for Expel, Inc.
Resolved
All delayed email messages have been sent, this issue is resolved.
Posted Sep 20, 2023 - 14:04 EDT
Update
We continue to investigate the email delays, but the backlog is no longer growing. Another update will be posted no later than 4 PM EDT
Posted Sep 20, 2023 - 12:59 EDT
Update
Some email notifications continue to be delayed, we are investigating additional fixes to help reduce the backlog more quickly. Another update will be provided no later than 1 PM EDT.
Posted Sep 20, 2023 - 11:58 EDT
Update
We have identified the issue and are working on a fix. Another update will be provided no later than 12 PM EDT
Posted Sep 20, 2023 - 11:02 EDT
Investigating
Some email notifications are delayed. We are currently investigating the issue and will provide an update no later than 11:00 AM EDT.
Posted Sep 20, 2023 - 10:13 EDT
This incident affected: Notifications (Email).