Slack global outage
Incident Report for Expel, Inc.
Resolved
Slack has confirmed that their service issues have been resolved with only minor issues still remaining with Google and outlook Calendars and some email notifications. Expel communications through slack are back to normal.
Posted Jan 04, 2021 - 15:35 EST
Identified
Slack is experiencing a global outage - see https://status.slack.com/2021-01/9ecc1bc75347b6d1 for details.

This means that customers may have trouble loading channels or connecting to Slack at this time. Workbench is unaffected and is fully operational. Don’t worry, our team is still monitoring your alerts 24/7 and will investigate and respond immediately to legitimate threats as we always do. Currently, there is no action to take on your part. Slack is investigating and we will follow up with more information as soon as we can. We apologize for any disruption caused.

Until Slack has resolved the issue, please contact your Engagement Manager for any questions or concerns.
Posted Jan 04, 2021 - 12:38 EST
This incident affected: Slack channels for customers.