Degraded investigative actions

Incident Report for Expel, Inc.

Resolved

We have implemented a fix and the issue seems to be resolved.
Posted Feb 01, 2023 - 17:40 EST

Update

We are continuing to investigate this issue.
Posted Feb 01, 2023 - 17:24 EST

Investigating

Investigative actions are currently degraded, we are actively investigating.
Posted Feb 01, 2023 - 17:24 EST
This incident affected: Workbench features (Investigative actions).