Workbench Connection Issues
Incident Report for Expel, Inc.
Resolved
Connectivity issues with Workbench have been resolved.
Posted Dec 22, 2022 - 17:41 EST
Investigating
We are currently investigating issues where some users are unable to connect to Workbench. We will provide an update around 18:00 EST.
Posted Dec 22, 2022 - 17:08 EST
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login) and Workbench features (Investigative actions, File uploads).