Workbench unavailable
Incident Report for Expel, Inc.
Resolved
This incident has been resolved and Workbench is now back up and running.
Posted 4 months ago. Apr 20, 2019 - 19:10 EDT
Identified
We have identified the cause of the incident and are executing multiple paths to recovery. We will post an update within thirty minutes.
Posted 4 months ago. Apr 20, 2019 - 19:02 EDT
This incident affected: Workbench availability (Workbench network connectivity, Workbench login) and Workbench features (Investigative actions, File uploads, Email notifications).