Delayed notifications

Incident Report for Expel, Inc.

Resolved

The backlog has been cleared and notifications are being delivered without delay.
Posted Feb 13, 2025 - 10:33 EST

Monitoring

There was a delay in processing some notifications by our upstream provider. The delayed messages are being processed and the backlog appears to be clearing. We are monitoring the issue and will post an update no later than 11:00 AM EST.
Posted Feb 13, 2025 - 10:19 EST
This incident affected: Notifications (Email, Slack, Teams, Ticketing systems (via email, such as Jira), PagerDuty, Opsgenie).