Phishing Service Sending Multiple Notifications

Incident Report for Expel, Inc.

Resolved

The hotfix for phishing submission outcome emails was successful and behavior has returned to normal. This incident is resolved.
Posted Jan 07, 2026 - 17:54 EST

Monitoring

The hotfix for duplicate phishing outcomes has been deployed and we are monitoring. Next update at 6pm EST.
Posted Jan 07, 2026 - 17:00 EST

Identified

We believe we have identified the root cause of duplicate phishing outcome emails and are preparing a hotfix. Next update at 5pm EST.
Posted Jan 07, 2026 - 16:11 EST

Investigating

Starting 1/6/25 at roughly 12:00 EST, we have identified an issue with our phishing service where outcome emails are being sent multiple times to some users and are investigating the root cause. Ingestion and email review are not affected. We will provide an update at 4pm EST.
Posted Jan 07, 2026 - 14:51 EST