Issues using Workbench
Incident Report for Expel, Inc.
Resolved
Workbench functionality has been restored.
Posted 8 months ago. Dec 30, 2018 - 01:37 EST
Investigating
Workbench or workbench features may be unavailable. We're currently investigating the problem. An update will be supplied by 6:30 UTC.
Posted 8 months ago. Dec 30, 2018 - 00:43 EST
This incident affected: Workbench availability (Workbench network connectivity, Workbench login).